In short
- CVE-2023-39322 is a HIGH (CVSS 7.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.4% of all vulnerabilities.
- Fix: update to 1.21.1 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.21.0-0, < 1.21.1
| 1.21.1
|
| go | ≥ 1.21.0, < 1.21.1
| 1.21.1
|
Description
QUIC connections do not set an upper bound on the amount of data buffered when reading post-handshake messages, allowing a malicious QUIC connection to cause unbounded memory growth.
With fix, connections now consistently reject messages larger than 65KiB in size.
NVD description
QUIC connections do not set an upper bound on the amount of data buffered when reading post-handshake messages, allowing a malicious QUIC connection to cause unbounded memory growth. With fix, connections now consistently reject messages larger than 65KiB in size.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free