In short
- CVE-2023-39659 is a CRITICAL (CVSS 9.8) vulnerability affecting langchain, langchain (langchain).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.8% of all vulnerabilities.
- Fix: update to 0.0.233, 0.0.325 or later.
| Package | Affected versions | Patched versions |
|---|
| langchain PyPI | < 0.0.233< 0.0.325
| 0.0.2330.0.325
|
| langchain | ≤ 0.0.232
| No fix yet |
Description
An issue in langchain langchain-ai before version 0.0.325 allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.
NVD description
An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free