In short
- CVE-2023-39662 is a CRITICAL (CVSS 9.8) vulnerability affecting llama-index, llamaindex (llamaindex project).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.1% of all vulnerabilities.
- Fix: update to 0.7.14, 0.9.14 or later.
| Package | Affected versions | Patched versions |
|---|
| llama-index PyPI | < 0.7.14< 0.9.14
| 0.7.140.9.14
|
| llamaindex | ≤ 0.7.13
| No fix yet |
Description
An issue in llama_index v.0.7.13 and before allows a remote attacker to execute arbitrary code via the exec parameter in PandasQueryEngine function.
NVD description
An issue in llama_index v.0.7.13 and before allows a remote attacker to execute arbitrary code via the `exec` parameter in PandasQueryEngine function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free