In short
- CVE-2023-39964 is a HIGH (CVSS 7.5) vulnerability affecting github.com/1Panel-dev/1Panel, 1panel (fit2cloud).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 62.0% of all vulnerabilities.
- Fix: update to 1.5.0 or later.
Description
Summary
Arbitrary file reads allow an attacker to read arbitrary important configuration files on the server.
Details
In the api/v1/file.go file, there is a function called LoadFromFile, which directly reads the file by obtaining the requested path parameter[path]. The request parameters are not filtered, resulting in a background arbitrary file reading vulnerability
PoC
Request /api/v1/files/loadfile, carry /etc/passwd data to read, as shown below:
Impact
1Panel v1.4.3
NVD description
1Panel is an open source Linux server operation and maintenance management panel. In version 1.4.3, arbitrary file reads allow an attacker to read arbitrary important configuration files on the server. In the `api/v1/file.go` file, there is a function called `LoadFromFile`, which directly reads the file by obtaining the requested path `parameter[path]`. The request parameters are not filtered, resulting in a background arbitrary file reading vulnerability. Version 1.5.0 has a patch for this issue.
More vulnerabilities in github.com/1Panel-dev/1Panel
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free