In short
- CVE-2023-41936 is a HIGH (CVSS 7.5) vulnerability affecting org.jenkins-ci.plugins:google-login, google login (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.81%, higher than 56.9% of all vulnerabilities.
- Fix: update to 1.8 or later.
Description
Jenkins Google Login Plugin 1.7 and earlier uses a non-constant time comparison function when checking whether the provided and expected token are equal, potentially allowing attackers to use statistical methods to obtain a valid token.
NVD description
Jenkins Google Login Plugin 1.7 and earlier uses a non-constant time comparison function when checking whether the provided and expected token are equal, potentially allowing attackers to use statistical methods to obtain a valid token.
More vulnerabilities in org.jenkins-ci.plugins:google-login
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free