In short
- CVE-2023-42439 is a MEDIUM (CVSS 6.5) vulnerability affecting geonode, geonode (geosolutionsgroup).
- Chance of exploitation in the next 30 days (EPSS): 0.96%, higher than 61.6% of all vulnerabilities.
- Fix: update to 4.1.3.post1, 4.1.3 or later.
| Package | Affected versions | Patched versions |
|---|
| geonode PyPI | ≥ 3.2.0, < 4.1.3.post1≥ 3.2.0
| 4.1.3.post1
|
| geonode | ≥ 3.2.0, < 4.1.3
| 4.1.3
|
Description
A SSRF vulnerability exists, bypassing existing controls on the software. This can allow a user to request internal services for a full read SSRF, returning any data from the internal network.
the application is using a whitelist, but the whitelist can be bypassed with @ and encoded value of @ (%40) GET /proxy/?url=http://development.demo.geonode.org%40geoserver:8080/geoserver/web
This will trick the application that the first host is a whitelisted address, but the browser will use @ or %40 as a credential to the host geoserver on port 8080, this will return the data to that host on the response.
NVD description
GeoNode is an open source platform that facilitates the creation, sharing, and collaborative use of geospatial data. A SSRF vulnerability exists starting in version 3.2.0, bypassing existing controls on the software. This can allow a user to request internal services for a full read SSRF, returning any data from the internal network. The application is using a whitelist, but the whitelist can be bypassed. The bypass will trick the application that the first host is a whitelisted address, but the browser will use `@` or `%40` as a credential to the host geoserver on port 8080, this will return the data to that host on the response. Version 4.1.3.post1 is the first available version that contains a patch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free