In short
- CVE-2023-42441 is a MEDIUM (CVSS 5.3) vulnerability affecting vyper, vyper (vyperlang).
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.8% of all vulnerabilities.
- Fix: update to 0.3.10 or later.
| Package | Affected versions | Patched versions |
|---|
| vyper PyPI | ≥ 0.2.9, < 0.3.10
| 0.3.10
|
| vyper | ≥ 0.2.9, < 0.3.10
| 0.3.10
|
Description
Impact
Locks of the type @nonreentrant("") or @nonreentrant('') do not produce reentrancy checks at runtime.
@nonreentrant("") # unprotected
@external
def bar():
pass
@nonreentrant("lock") # protected
@external
def foo():
pass
Patches
Patched in #3605
Workarounds
The lock name should be a non-empty string.
References
Are there any links users can visit to find out more?
NVD description
Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine (EVM). Starting in version 0.2.9 and prior to version 0.3.10, locks of the type `@nonreentrant("")` or `@nonreentrant('')` do not produce reentrancy checks at runtime. This issue is fixed in version 0.3.10. As a workaround, ensure the lock name is a non-empty string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free