In short
- CVE-2023-42781 is a MEDIUM (CVSS 6.5) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.6% of all vulnerabilities.
- Fix: update to 2.7.3 or later.
Description
Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs. This is a different issue than CVE-2023-42663 but leading to similar outcome.
Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.
NVD description
Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs. This is a different issue than CVE-2023-42663 but leading to similar outcome.
Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free