In short
- CVE-2023-42818 is a CRITICAL (CVSS 9.8) vulnerability affecting github.com/jumpserver/jumpserver, github.com/jumpserver/koko, jumpserver (fit2cloud).
- Chance of exploitation in the next 30 days (EPSS): 0.68%, higher than 52.2% of all vulnerabilities.
- Fix: update to 3.6.5+incompatible, 3.5.6+incompatible, 3.6.5, 3.5.6 or later.
Description
SSH public key login without private key challenge if mfa is enabled in jumpserver in github.com/jumpserver/koko in github.com/jumpserver/jumpserver
NVD description
JumpServer is an open source bastion host. When users enable MFA and use a public key for authentication, the Koko SSH server does not verify the corresponding SSH private key. An attacker could exploit a vulnerability by utilizing a disclosed public key to attempt brute-force authentication against the SSH service This issue has been patched in versions 3.6.5 and 3.5.6. Users are advised to upgrade. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free