In short
- CVE-2023-4316 is a HIGH (CVSS 7.5) vulnerability affecting zod (zod), zod.
- Chance of exploitation in the next 30 days (EPSS): 0.92%, higher than 60.7% of all vulnerabilities.
- Fix: update to 3.22.3 or later.
| Package | Affected versions | Patched versions |
|---|
| zod | = 3.22.2
| No fix yet |
| zod npm | < 3.22.3
| 3.22.3
|
Description
Zod version 3.22.2 allows an attacker to perform a denial of service while validating emails.
NVD description
Zod in versions 3.21.0 up to and including 3.22.3 allows an attacker to perform a denial of service while validating emails.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free