In short
- CVE-2023-43655 is a HIGH (CVSS 8.8) vulnerability affecting composer/composer, composer (getcomposer).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.8% of all vulnerabilities.
- Fix: update to 2.2.22, 2.6.4, 1.10.27, 2.2.21 or later.
| Package | Affected versions | Patched versions |
|---|
| composer/composer Packagist | ≥ 2.0.0, < 2.2.22≥ 2.3.0, < 2.6.4< 1.10.27
| 2.2.222.6.41.10.27
|
| composer | ≥ 2.0.0, < 2.2.21≥ 2.3.0, < 2.6.4< 1.10.27
| 2.2.212.6.41.10.27
|
Description
Impact
Users publishing a composer.phar to a public web-accessible server where the composer.phar can be executed as a php file may be impacted if PHP also has register_argc_argv enabled in php.ini.
Patches
2.6.4, 2.2.22 and 1.10.27 patch this vulnerability.
Workarounds
Make sure register_argc_argv is disabled in php.ini, and avoid publishing composer.phar to the web as this really should not happen.
NVD description
Composer is a dependency manager for PHP. Users publishing a composer.phar to a public web-accessible server where the composer.phar can be executed as a php file may be subject to a remote code execution vulnerability if PHP also has `register_argc_argv` enabled in php.ini. Versions 2.6.4, 2.2.22 and 1.10.27 patch this vulnerability. Users are advised to upgrade. Users unable to upgrade should make sure `register_argc_argv` is disabled in php.ini, and avoid publishing composer.phar to the web as this is not best practice.
More vulnerabilities in composer/composer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free