In short
- CVE-2023-45311 is a CRITICAL (CVSS 9.8) vulnerability affecting fsevents (fsevents project), fsevents.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.4% of all vulnerabilities.
- Fix: update to 1.2.11 or later.
| Package | Affected versions | Patched versions |
|---|
| fsevents | < 1.2.11
| 1.2.11
|
| fsevents npm | < 1.2.11
| 1.2.11
|
Description
fsevents before 1.2.11 depends on the https://fsevents-binaries.s3-us-west-2.amazonaws.com URL, which might allow an adversary to execute arbitrary code if any JavaScript project (that depends on fsevents) distributes code that was obtained from that URL at a time when it was controlled by an adversary.
NVD description
fsevents before 1.2.11 depends on the https://fsevents-binaries.s3-us-west-2.amazonaws.com URL, which might allow an adversary to execute arbitrary code if any JavaScript project (that depends on fsevents) distributes code that was obtained from that URL at a time when it was controlled by an adversary. NOTE: some sources feel that this means that no version is affected any longer, because the URL is not controlled by an adversary.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free