In short
- CVE-2023-45857 is a MEDIUM (CVSS 6.5) vulnerability affecting axios (axios), axios.
- Chance of exploitation in the next 30 days (EPSS): 0.73%, higher than 54.2% of all vulnerabilities.
- Fix: update to 0.28.0, 1.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| axios | = 1.5.1
| No fix yet |
| axios npm | ≥ 0.8.1, < 0.28.0≥ 1.0.0, < 1.6.0
| 0.28.01.6.0
|
Description
An issue discovered in Axios 0.8.1 through 1.5.1 inadvertently reveals the confidential XSRF-TOKEN stored in cookies by including it in the HTTP header X-XSRF-TOKEN for every request made to any host allowing attackers to view sensitive information.
NVD description
An issue discovered in Axios 1.5.1 inadvertently reveals the confidential XSRF-TOKEN stored in cookies by including it in the HTTP header X-XSRF-TOKEN for every request made to any host allowing attackers to view sensitive information.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free