In short
- CVE-2023-46119 is a HIGH (CVSS 7.5) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.8% of all vulnerabilities.
- Fix: update to 5.5.6, 6.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 1.0.0, < 5.5.6≥ 6.0.0, < 6.3.1
| 5.5.66.3.1
|
| parse-server npm | ≥ 1.0.0, < 5.5.6≥ 6.0.0, < 6.3.1
| 5.5.66.3.1
|
Description
Impact
Parse Server crashes when uploading a file without extension.
Patches
A permanent fix has been implemented to prevent the server from crashing.
Workarounds
There are no known workarounds.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Parse Server crashes when uploading a file without extension. This vulnerability has been patched in versions 5.5.6 and 6.3.1.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free