In short
- CVE-2023-46324 is a HIGH (CVSS 7.5) vulnerability affecting github.com/free5gc/udm, udm (free5gc).
- Chance of exploitation in the next 30 days (EPSS): 0.50%, higher than 43.0% of all vulnerabilities.
- Fix: update to 1.2.0 or later.
Description
pkg/suci/suci.go in free5GC udm before 1.2.0, when Go before 1.19 is used, allows an Invalid Curve Attack because it may compute a shared secret via an uncompressed public key that has not been validated. An attacker can send arbitrary SUCIs to the UDM, which tries to decrypt them via both its private key and the attacker's public key.
NVD description
pkg/suci/suci.go in free5GC udm before 1.2.0, when Go before 1.19 is used, allows an Invalid Curve Attack because it may compute a shared secret via an uncompressed public key that has not been validated. An attacker can send arbitrary SUCIs to the UDM, which tries to decrypt them via both its private key and the attacker's public key.
More vulnerabilities in github.com/free5gc/udm
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free