In short
- CVE-2023-46729 is a MEDIUM (CVSS 6.1) vulnerability affecting sentry software development kit (sentry), @sentry/nextjs.
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.3% of all vulnerabilities.
- Fix: update to 7.77.0 or later.
Description
Impact
An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This could open door for other attack vectors:
- client-side vulnerabilities: XSS/CSRF in the context of the trusted domain;
- interaction with internal network;
- read cloud metadata endpoints (AWS, Azure, Google Cloud, etc.);
- local/remote port scan.
This issue only affects users who have Next.js SDK tunneling feature enabled.
Patches
The problem has been fixed in sentry/[email protected]
Workarounds
Disable tunneling by removing the tunnelRoute option from Sentry Next.js SDK config — next.config.js or next.config.mjs.
References
Credits
NVD description
sentry-javascript provides Sentry SDKs for JavaScript. An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This issue only affects users who have Next.js SDK tunneling feature enabled. The problem has been fixed in version 7.77.0.
More vulnerabilities in sentry software development kit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free