In short
- CVE-2023-48052 is a HIGH (CVSS 7.4) vulnerability affecting httpie, httpie (httpie).
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 23.4% of all vulnerabilities.
- Fix: update to 3.2.3 or later.
| Package | Affected versions | Patched versions |
|---|
| httpie PyPI | < 3.2.3all versions
| 3.2.3
|
| httpie | = 3.2.2
| No fix yet |
Description
Missing SSL certificate validation in HTTPie v3.2.2 allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack.
NVD description
Missing SSL certificate validation in HTTPie v3.2.2 allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free