In short
- CVE-2023-48714 is a MEDIUM (CVSS 4.3) vulnerability affecting silverstripe/framework, framework (silverstripe).
- Chance of exploitation in the next 30 days (EPSS): 0.36%, higher than 29.3% of all vulnerabilities.
- Fix: update to 5.1.11, 4.13.39 or later.
| Package | Affected versions | Patched versions |
|---|
| silverstripe/framework Packagist | ≥ 5.0.0, < 5.1.11< 4.13.39
| 5.1.114.13.39
|
| framework | ≥ 5.0.0, < 5.1.11< 4.13.39
| 5.1.114.13.39
|
Description
Impact
If a user should not be able to see a record, but that record can be added to a GridField using the GridFieldAddExistingAutocompleter component, the record's title can be accessed by that user.
Base CVSS: 4.3
Reported by: Nick K - LittleMonkey, littlemonkey.co.nz
References
NVD description
Silverstripe Framework is the framework that forms the base of the Silverstripe content management system. Prior to versions 4.13.39 and 5.1.11, if a user should not be able to see a record, but that record can be added to a `GridField` using the `GridFieldAddExistingAutocompleter` component, the record's title can be accessed by that user. Versions 4.13.39 and 5.1.11 contain a fix for this issue.
More vulnerabilities in silverstripe/framework
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free