| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.struts:struts2-core | ≥ 2.0.0, < 2.5.33≥ 6.0.0, < 6.3.0.2 | 2.5.336.3.0.2 |
| struts | ≥ 2.0.0, < 2.5.33≥ 6.0.0, < 6.3.0.2 | 2.5.336.3.0.2 |
An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free