In short
- CVE-2023-50248 is a MEDIUM (CVSS 6.5) vulnerability affecting ckan, ckan (okfn).
- Chance of exploitation in the next 30 days (EPSS): 0.58%, higher than 47.7% of all vulnerabilities.
- Fix: update to 2.9.10, 2.10.3 or later.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.0, < 2.9.10≥ 2.10.0, < 2.10.3
| 2.9.102.10.3
|
| ckan | ≥ 2.0, < 2.9.10≥ 2.10.0, < 2.10.3
| 2.9.102.10.3
|
Description
Impact
When submitting a POST request to the /dataset/new endpoint (including either the auth cookie or the Authorization header) with a specially-crafted field, an attacker can create an out-of-memory error in the hosting server.
To trigger this error the user needs to have permissions to create or edit datasets.
Patches
This vulnerability has been patched in CKAN 2.10.3 and 2.9.10
NVD description
CKAN is an open-source data management system for powering data hubs and data portals. Starting in version 2.0.0 and prior to versions 2.9.10 and 2.10.3, when submitting a POST request to the `/dataset/new` endpoint (including either the auth cookie or the `Authorization` header) with a specially-crafted field, an attacker can create an out-of-memory error in the hosting server. To trigger this error, the attacker need to have permissions to create or edit datasets. This vulnerability has been patched in CKAN 2.10.3 and 2.9.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free