In short
- CVE-2023-51232 is a HIGH (CVSS 7.5) vulnerability affecting dagster.
- Chance of exploitation in the next 30 days (EPSS): 0.95%, higher than 61.4% of all vulnerabilities.
- Fix: update to 1.5.11 or later.
| Package | Affected versions | Patched versions |
|---|
| dagster PyPI | < 1.5.11
| 1.5.11
|
Description
Directory Traversal vulnerability in dagster-webserver Dagster thru 1.5.10 allows remote attackers to obtain sensitive information via crafted request to the /logs endpoint. This may be restricted to certain file names that start with a dot ('.').
NVD description
Directory Traversal vulnerability in dagster-webserver Dagster thru 1.5.11 allows remote attackers to obtain sensitive information via crafted request to the /logs endpoint. This may be restricted to certain file names that start with a dot ('.').
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free