In short
- CVE-2023-6148 is a MEDIUM (CVSS 5.4) vulnerability affecting com.qualys.plugins:qualys-pc, policy compliance (qualys).
- Chance of exploitation in the next 30 days (EPSS): 0.46%, higher than 39.7% of all vulnerabilities.
- Fix: update to 1.0.6 or later.
Description
Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data.
NVD description
Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data
More vulnerabilities in com.qualys.plugins:qualys-pc
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free