In short
- CVE-2024-10188 is a HIGH (CVSS 7.5) vulnerability affecting litellm.
- Chance of exploitation in the next 30 days (EPSS): 0.57%, higher than 47.1% of all vulnerabilities.
- Fix: update to 1.53.1.dev1 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.53.1.dev1
| 1.53.1.dev1
|
Description
A vulnerability in BerriAI/litellm, as of commit 26c03c9, allows unauthenticated users to cause a Denial of Service (DoS) by exploiting the use of ast.literal_eval to parse user input. This function is not safe and is prone to DoS attacks, which can crash the litellm Python server.
NVD description
A vulnerability in BerriAI/litellm, as of commit 26c03c9, allows unauthenticated users to cause a Denial of Service (DoS) by exploiting the use of ast.literal_eval to parse user input. This function is not safe and is prone to DoS attacks, which can crash the litellm Python server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free