In short
- CVE-2024-10553 is a CRITICAL (CVSS 9.8) vulnerability affecting ai.h2o:h2o-core, h2o, h2o (h2o).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.6% of all vulnerabilities.
- Fix: update to 3.46.0.6 or later.
| Package | Affected versions | Patched versions |
|---|
| ai.h2o:h2o-core Maven | < 3.46.0.6
| 3.46.0.6
|
| h2o PyPI | < 3.46.0.6
| 3.46.0.6
|
| h2o | = 3.46.0.4
| No fix yet |
Description
A vulnerability in the h2oai/h2o-3 REST API versions 3.46.0.4 allows unauthenticated remote attackers to execute arbitrary code via deserialization of untrusted data. The vulnerability exists in the endpoints POST /99/ImportSQLTable and POST /3/SaveToHiveTable, where user-controlled JDBC URLs are passed to DriverManager.getConnection, leading to deserialization if a MySQL or PostgreSQL driver is available in the classpath. This issue is fixed in version 3.46.0.6.
NVD description
A vulnerability in the h2oai/h2o-3 REST API versions 3.46.0.4 allows unauthenticated remote attackers to execute arbitrary code via deserialization of untrusted data. The vulnerability exists in the endpoints POST /99/ImportSQLTable and POST /3/SaveToHiveTable, where user-controlled JDBC URLs are passed to DriverManager.getConnection, leading to deserialization if a MySQL or PostgreSQL driver is available in the classpath. This issue is fixed in version 3.47.0.
More vulnerabilities in ai.h2o:h2o-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free