In short
- CVE-2024-10940 is a MEDIUM (CVSS 5.3) vulnerability affecting langchain-core.
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 33.8% of all vulnerabilities.
- Fix: update to 0.1.53, 0.2.43, 0.3.15 or later.
| Package | Affected versions | Patched versions |
|---|
| langchain-core PyPI | ≥ 0.1.17, < 0.1.53≥ 0.2.0, < 0.2.43≥ 0.3.0, < 0.3.15
| 0.1.530.2.430.3.15
|
Description
A vulnerability in langchain-core versions >=0.1.17,<0.1.53, >=0.2.0,<0.2.43, and >=0.3.0,<0.3.15 allows unauthorized users to read arbitrary files from the host file system. The issue arises from the ability to create langchain_core.prompts.ImagePromptTemplate's (and by extension langchain_core.prompts.ChatPromptTemplate's) with input variables that can read any user-specified path from the server file system. If the outputs of these prompt templates are exposed to the user, either directly or through downstream model outputs, it can lead to the exposure of sensitive information.
NVD description
A vulnerability in langchain-core versions >=0.1.17,<0.1.53, >=0.2.0,<0.2.43, and >=0.3.0,<0.3.15 allows unauthorized users to read arbitrary files from the host file system. The issue arises from the ability to create langchain_core.prompts.ImagePromptTemplate's (and by extension langchain_core.prompts.ChatPromptTemplate's) with input variables that can read any user-specified path from the server file system. If the outputs of these prompt templates are exposed to the user, either directly or through downstream model outputs, it can lead to the exposure of sensitive information.
More vulnerabilities in langchain-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free