In short
- CVE-2024-1483 is a HIGH (CVSS 7.5) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 86.0% of all vulnerabilities.
- Fix: update to 2.12.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.12.1
| 2.12.1
|
| mlflow | < 2.12.1
| 2.12.1
|
Description
A path traversal vulnerability exists in mlflow/mlflow version 2.9.2, allowing attackers to access arbitrary files on the server. By crafting a series of HTTP POST requests with specially crafted 'artifact_location' and 'source' parameters, using a local URI with '#' instead of '?', an attacker can traverse the server's directory structure. The issue occurs due to insufficient validation of user-supplied input in the server's handlers.
NVD description
A path traversal vulnerability exists in mlflow/mlflow version 2.9.2, allowing attackers to access arbitrary files on the server. By crafting a series of HTTP POST requests with specially crafted 'artifact_location' and 'source' parameters, using a local URI with '#' instead of '?', an attacker can traverse the server's directory structure. The issue occurs due to insufficient validation of user-supplied input in the server's handlers.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free