In short
- CVE-2024-1593 is a HIGH (CVSS 7.5) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.70%, higher than 53.3% of all vulnerabilities.
- Fix: update to 2.11.3 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | ≤ 2.9.2
| No fix yet |
| mlflow | < 2.11.3
| 2.11.3
|
Description
A path traversal vulnerability exists in the mlflow/mlflow repository due to improper handling of URL parameters. By smuggling path traversal sequences using the ';' character in URLs, attackers can manipulate the 'params' portion of the URL to gain unauthorized access to files or directories. This vulnerability allows for arbitrary data smuggling into the 'params' part of the URL, enabling attacks similar to those described in previous reports but utilizing the ';' character for parameter smuggling. Successful exploitation could lead to unauthorized information disclosure or server compromise.
NVD description
A path traversal vulnerability exists in the mlflow/mlflow repository due to improper handling of URL parameters. By smuggling path traversal sequences using the ';' character in URLs, attackers can manipulate the 'params' portion of the URL to gain unauthorized access to files or directories. This vulnerability allows for arbitrary data smuggling into the 'params' part of the URL, enabling attacks similar to those described in previous reports but utilizing the ';' character for parameter smuggling. Successful exploitation could lead to unauthorized information disclosure or server compromise.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free