In short
- CVE-2024-1594 is a HIGH (CVSS 7.5) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.71%, higher than 53.6% of all vulnerabilities.
- Fix: update to 2.11.3 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | ≤ 2.9.2
| No fix yet |
| mlflow | < 2.11.3
| 2.11.3
|
Description
A path traversal vulnerability exists in the mlflow/mlflow repository, specifically within the handling of the artifact_location parameter when creating an experiment. Attackers can exploit this vulnerability by using a fragment component # in the artifact location URI to read arbitrary files on the server in the context of the server's process. This issue is similar to CVE-2023-6909 but utilizes a different component of the URI to achieve the same effect.
NVD description
A path traversal vulnerability exists in the mlflow/mlflow repository, specifically within the handling of the `artifact_location` parameter when creating an experiment. Attackers can exploit this vulnerability by using a fragment component `#` in the artifact location URI to read arbitrary files on the server in the context of the server's process. This issue is similar to CVE-2023-6909 but utilizes a different component of the URI to achieve the same effect.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free