In short
- CVE-2024-21488 is a CRITICAL (CVSS 9.8) vulnerability affecting network (forkhq), network.
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.6% of all vulnerabilities.
- Fix: update to 0.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| network | < 0.7.0
| 0.7.0
|
| network npm | < 0.7.0
| 0.7.0
|
Description
Versions of the package network before 0.7.0 are vulnerable to Arbitrary Command Injection due to use of the child_process exec function without input sanitization. If (attacker-controlled) user input is given to the mac_address_for function of the package, it is possible for an attacker to execute arbitrary commands on the operating system that this package is being run on.
NVD description
Versions of the package network before 0.7.0 are vulnerable to Arbitrary Command Injection due to use of the child_process exec function without input sanitization. If (attacker-controlled) user input is given to the mac_address_for function of the package, it is possible for the attacker to execute arbitrary commands on the operating system that this package is being run on.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free