In short
- CVE-2024-21509 is a MEDIUM (CVSS 6.5) vulnerability affecting mysql2 (sidorares), mysql2.
- Chance of exploitation in the next 30 days (EPSS): 0.95%, higher than 61.5% of all vulnerabilities.
- Fix: update to 3.9.4 or later.
| Package | Affected versions | Patched versions |
|---|
| mysql2 | < 3.9.4
| 3.9.4
|
| mysql2 npm | < 3.9.4
| 3.9.4
|
Description
Versions of the package mysql2 before 3.9.4 are vulnerable to Prototype Poisoning due to insecure results object creation and improper user input sanitization passed through parserFn in text_parser.js and binary_parser.js.
NVD description
Versions of the package mysql2 before 3.9.4 are vulnerable to Prototype Poisoning due to insecure results object creation and improper user input sanitization passed through parserFn in text_parser.js and binary_parser.js.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free