In short
- CVE-2024-21529 is a HIGH (CVSS 8.2) vulnerability affecting dset.
- Chance of exploitation in the next 30 days (EPSS): 0.75%, higher than 55.3% of all vulnerabilities.
- Fix: update to 3.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| dset npm | < 3.1.4
| 3.1.4
|
Description
Versions of the package dset before 3.1.4 are vulnerable to Prototype Pollution via the dset function due improper user input sanitization. This vulnerability allows the attacker to inject malicious object property using the built-in Object property proto, which is recursively assigned to all the objects in the program.
NVD description
Versions of the package dset before 3.1.4 are vulnerable to Prototype Pollution via the dset function due improper user input sanitization. This vulnerability allows the attacker to inject malicious object property using the built-in Object property __proto__, which is recursively assigned to all the objects in the program.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free