In short
- CVE-2024-21534 is a CRITICAL (CVSS 9.8) vulnerability affecting org.webjars.npm:jsonpath-plus, jsonpath-plus.
- Chance of exploitation in the next 30 days (EPSS): 9.0%, higher than 95.3% of all vulnerabilities.
- Fix: update to 10.2.0 or later.
Description
Versions of the package jsonpath-plus before 10.0.7 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node.
Note:
There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads
NVD description
All versions of the package jsonpath-plus are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node.
**Note:**
There were several attempts to fix it in versions [10.0.0-10.1.0](https://github.com/JSONPath-Plus/JSONPath/compare/v9.0.0...v10.1.0) but it could still be exploited using [different payloads](https://github.com/JSONPath-Plus/JSONPath/issues/226).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free