In short
- CVE-2024-21542 is a HIGH (CVSS 8.6) vulnerability affecting luigi.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.6% of all vulnerabilities.
- Fix: update to 3.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| luigi PyPI | < 3.6.0
| 3.6.0
|
Description
Versions of the package luigi before 3.6.0 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) due to improper destination file path validation in the _extract_packages_archive function.
NVD description
Versions of the package luigi before 3.6.0 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) due to improper destination file path validation in the _extract_packages_archive function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free