In short
- CVE-2024-21546 is a CRITICAL (CVSS 9.8) vulnerability affecting unisharp/laravel-filemanager.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.8% of all vulnerabilities.
- Fix: update to 2.9.1 or later.
Description
Versions of the package unisharp/laravel-filemanager before 2.9.1 are vulnerable to Remote Code Execution (RCE) through using a valid mimetype and inserting the . character after the php file extension. This allows the attacker to execute malicious code.
NVD description
Versions of the package unisharp/laravel-filemanager before 2.9.1 are vulnerable to Remote Code Execution (RCE) through using a valid mimetype and inserting the . character after the php file extension. This allows the attacker to execute malicious code.
More vulnerabilities in unisharp/laravel-filemanager
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free