| Package | Affected versions | Patched versions |
|---|---|---|
| puma | ≥ 6.0.0, < 6.4.2< 5.6.8 | 6.4.25.6.8 |
| puma | ≥ 6.0.0, < 6.4.2< 5.6.8 | 6.4.25.6.8 |
Prior to versions 6.4.2 and 5.6.8, puma exhibited dangerous behavior when parsing chunked transfer encoding bodies.
Fixed versions limit the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption.
The vulnerability has been fixed in 6.4.2 and 5.6.8.
No known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free