In short
- CVE-2024-21649 is a HIGH (CVSS 8.8) vulnerability affecting vantage6, vantage6 (vantage6).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 69.7% of all vulnerabilities.
- Fix: update to 4.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vantage6 PyPI | < 4.2.0
| 4.2.0
|
| vantage6 | < 4.2.0
| 4.2.0
|
Description
Impact
Authenticated users could inject code into algorithm environment variables
Workarounds
No
NVD description
The vantage6 technology enables to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC). Prior to 4.2.0, authenticated users could inject code into algorithm environment variables, resulting in remote code execution. This vulnerability is patched in 4.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free