| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 8.5.7, < 8.5.64≥ 9.0.0-M11, < 9.0.44 | 8.5.649.0.44 |
| org.apache.tomcat.experimental:tomcat-embed-programmatic | ≥ 9.0.43, < 9.0.44 | 9.0.44 |
| org.apache.tomcat:tomcat-coyote | ≥ 8.5.7, < 8.5.64≥ 9.0.0-M11, < 9.0.44 | 8.5.649.0.44 |
| tomcat | = 9.0.0≥ 8.5.7, < 8.5.64≥ 9.0.1, < 9.0.44 | 8.5.649.0.44 |
Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43.
Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free