In short
- CVE-2024-22233 is a HIGH (CVSS 7.5) vulnerability affecting org.springframework:spring-core, spring framework (vmware).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.2% of all vulnerabilities.
- Fix: update to 6.0.16, 6.1.3 or later.
Description
In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition.
Specifically, an application is vulnerable when all of the following are true:
- the application uses Spring MVC
- Spring Security 6.1.6+ or 6.2.1+ is on the classpath
Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.
NVD description
In Spring Framework versions 6.0.15 and 6.1.2, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition.
Specifically, an application is vulnerable when all of the following are true:
* the application uses Spring MVC
* Spring Security 6.1.6+ or 6.2.1+ is on the classpath
Typically, Spring Boot applications need the org.springframework.boot:spring-boot-starter-web and org.springframework.boot:spring-boot-starter-security dependencies to meet all conditions.
More vulnerabilities in org.springframework:spring-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free