In short
- CVE-2024-22243 is a HIGH (CVSS 8.1) vulnerability affecting org.springframework:spring-web.
- Chance of exploitation in the next 30 days (EPSS): 4.0%, higher than 90.5% of all vulnerabilities.
- Fix: update to 5.3.32, 6.0.17, 6.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| org.springframework:spring-web Maven | ≥ 5.3.0, < 5.3.32≥ 6.0.0, < 6.0.17≥ 6.1.0, < 6.1.4≤ 5.2.25.RELEASE
| 5.3.326.0.176.1.4
|
Description
Applications that use UriComponentsBuilder to parse an externally provided URL (e.g. through a query parameter) AND perform validation checks on the host of the parsed URL may be vulnerable to a open redirect attack or to a SSRF attack if the URL is used after passing validation checks.
NVD description
Applications that use UriComponentsBuilder to parse an externally provided URL (e.g. through a query parameter) AND perform validation checks on the host of the parsed URL may be vulnerable to a open redirect https://cwe.mitre.org/data/definitions/601.html attack or to a SSRF attack if the URL is used after passing validation checks.
More vulnerabilities in org.springframework:spring-web
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free