In short
- CVE-2024-22393 is a CRITICAL (CVSS 9.1) vulnerability affecting github.com/apache/incubator-answer, answer (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.4% of all vulnerabilities.
- Fix: update to 1.2.5 or later.
Description
Unrestricted Upload of File with Dangerous Type vulnerability in Apache Answer. This issue affects Apache Answer through 1.2.1.
Pixel Flood Attack by uploading large pixel files will cause server out of memory. A logged-in user can cause such an attack by uploading an image when posting content.
Users are recommended to upgrade to version 1.2.5, which fixes the issue.
NVD description
Unrestricted Upload of File with Dangerous Type vulnerability in Apache Answer.This issue affects Apache Answer: through 1.2.1.
Pixel Flood Attack by uploading large pixel files will cause server out of memory. A logged-in user can cause such an attack by uploading an image when posting content.
Users are recommended to upgrade to version [1.2.5], which fixes the issue.
More vulnerabilities in github.com/apache/incubator-answer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free