| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.seata:seata-core | ≥ 1.0.0, < 1.8.1≥ 2.0.0, < 2.1.0 | 1.8.12.1.0 |
| seata | = 2.0.0≥ 1.0.0, < 1.8.1 | 1.8.1 |
Deserialization of Untrusted Data vulnerability in Apache Seata.
When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol.
This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0.
Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free