In short
- CVE-2024-23118 is a HIGH (CVSS 7.2) vulnerability affecting centreon/centreon, centreon web (centreon).
- Chance of exploitation in the next 30 days (EPSS): 53.4%, higher than 99.0% of all vulnerabilities.
- Fix: update to 22.10.15, 22.10.17, 23.04.13, 23.10.5 or later.
| Package | Affected versions | Patched versions |
|---|
| centreon/centreon Packagist | < 22.10.15
| 22.10.15
|
| centreon web | ≥ 22.10.2, < 22.10.17≥ 23.04.0, < 23.04.13≥ 23.10.0, < 23.10.5< 22.04.19
| 22.10.1723.04.1323.10.522.04.19
|
Description
Centreon updateContactHostCommands SQL Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Centreon. Authentication is required to exploit this vulnerability.
The specific flaw exists within the updateContactHostCommands function. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-22298.
NVD description
Centreon updateContactHostCommands SQL Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Centreon. Authentication is required to exploit this vulnerability.
The specific flaw exists within the updateContactHostCommands function. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-22298.
More vulnerabilities in centreon/centreon
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free