In short
- CVE-2024-23349 is a MEDIUM (CVSS 5.4) vulnerability affecting github.com/apache/incubator-answer, answer (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.9% of all vulnerabilities.
- Fix: update to 1.2.5 or later.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer. This issue affects Apache Answer through 1.2.1.
XSS attack when user enters summary. A logged-in user, when modifying their own submitted question, can input malicious code in the summary to create such an attack.
Users are recommended to upgrade to version 1.2.5, which fixes the issue.
NVD description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: through 1.2.1.
XSS attack when user enters summary. A logged-in user, when modifying their own submitted question, can input malicious code in the summary to create such an attack.
Users are recommended to upgrade to version [1.2.5], which fixes the issue.
More vulnerabilities in github.com/apache/incubator-answer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free