In short
- CVE-2024-23653 is a CRITICAL (CVSS 9.8) vulnerability affecting github.com/moby/buildkit, buildkit (mobyproject).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 89.0% of all vulnerabilities.
- Fix: update to 0.12.5 or later.
Description
Impact
In addition to running containers as build steps, BuildKit also provides APIs for running interactive containers based on built images. It was possible to use these APIs to ask BuildKit to run a container with elevated privileges. Normally, running such containers is only allowed if special security.insecure entitlement is enabled both by buildkitd configuration and allowed by the user initializing the build request.
Patches
The issue has been fixed in v0.12.5 .
Workarounds
Avoid using BuildKit frontends from untrusted sources. A frontend image is usually specified as the #syntax line on your Dockerfile, or with --frontend flag when using buildctl build command.
References
NVD description
BuildKit is a toolkit for converting source code to build artifacts in an efficient, expressive and repeatable manner. In addition to running containers as build steps, BuildKit also provides APIs for running interactive containers based on built images. It was possible to use these APIs to ask BuildKit to run a container with elevated privileges. Normally, running such containers is only allowed if special `security.insecure` entitlement is enabled both by buildkitd configuration and allowed by the user initializing the build request. The issue has been fixed in v0.12.5 . Avoid using BuildKit frontends from untrusted sources.
More vulnerabilities in github.com/moby/buildkit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free