In short
- CVE-2024-23730 is a CRITICAL (CVSS 9.8) vulnerability affecting llama-hub, llamahub (llamahub).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.4% of all vulnerabilities.
- Fix: update to 0.0.67 or later.
| Package | Affected versions | Patched versions |
|---|
| llama-hub PyPI | < 0.0.67
| 0.0.67
|
| llamahub | < 0.0.67
| 0.0.67
|
Description
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
NVD description
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free