In short
- CVE-2024-23750 is a HIGH (CVSS 8.8) vulnerability affecting metagpt, metagpt (deepwisdom).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 61.8% of all vulnerabilities.
- Fix: update to 0.6.5 or later.
| Package | Affected versions | Patched versions |
|---|
| metagpt PyPI | ≤ 0.6.6< 0.6.5
| 0.6.5
|
| metagpt | ≤ 0.6.4
| No fix yet |
Description
MetaGPT through 0.6.4 allows the QaEngineer role to execute arbitrary code because RunCode.run_script() passes shell metacharacters to subprocess.Popen.
NVD description
MetaGPT through 0.6.4 allows the QaEngineer role to execute arbitrary code because RunCode.run_script() passes shell metacharacters to subprocess.Popen.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free