In short
- CVE-2024-23751 is a CRITICAL (CVSS 9.8) vulnerability affecting llama-index, llamaindex (llamaindex).
- Chance of exploitation in the next 30 days (EPSS): 0.66%, higher than 51.6% of all vulnerabilities.
- Fix: update to 0.9.35 or later.
| Package | Affected versions | Patched versions |
|---|
| llama-index PyPI | ≤ 0.9.35< 0.9.35
| 0.9.35
|
| llamaindex | ≤ 0.9.34
| No fix yet |
Description
LlamaIndex (aka llama_index) through 0.9.35 allows SQL injection via the Text-to-SQL feature in NLSQLTableQueryEngine, SQLTableRetrieverQueryEngine, NLSQLRetriever, RetrieverQueryEngine, and PGVectorSQLQueryEngine. For example, an attacker might be able to delete this year's student records via "Drop the Students table" within English language input.
NVD description
LlamaIndex (aka llama_index) through 0.9.34 allows SQL injection via the Text-to-SQL feature in NLSQLTableQueryEngine, SQLTableRetrieverQueryEngine, NLSQLRetriever, RetrieverQueryEngine, and PGVectorSQLQueryEngine. For example, an attacker might be able to delete this year's student records via "Drop the Students table" within English language input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free