| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.19≥ 11.0.0-M1, < 11.0.0-M17≥ 8.5.0, < 8.5.99≥ 9.0.0-M1, < 9.0.86 | 10.1.1911.0.0-M178.5.999.0.86 |
| org.apache.tomcat:tomcat-coyote | ≥ 10.1.0-M1, < 10.1.19≥ 11.0.0-M1, < 11.0.0-M17≥ 8.5.0, < 8.5.99≥ 9.0.0-M1, < 9.0.86 | 10.1.1911.0.0-M178.5.999.0.86 |
| tomcat | = 11.0.0≥ 10.1.0, < 10.1.19≥ 8.5.0, < 8.5.99≥ 9.0.0, < 9.0.86 | 10.1.198.5.999.0.86 |
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98.
Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free