In short
- CVE-2024-24556 is a MEDIUM (CVSS 6.1) vulnerability affecting urql (nearform), @urql/next.
- Chance of exploitation in the next 30 days (EPSS): 0.36%, higher than 29.2% of all vulnerabilities.
- Fix: update to 1.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| urql | < 1.1.1
| 1.1.1
|
| @urql/next npm | < 1.1.1
| 1.1.1
|
Description
impact
The @urql/next package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns html tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream.
To fix this vulnerability upgrade to version 1.1.1
NVD description
urql is a GraphQL client that exposes a set of helpers for several frameworks. The `@urql/next` package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns `html` tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream. To fix this vulnerability upgrade to version 1.1.1
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free