In short
- CVE-2024-25981 is a MEDIUM (CVSS 5.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.58%, higher than 47.7% of all vulnerabilities.
- Fix: update to 4.2.6, 4.3.3, 4.1.9 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.2.0, < 4.2.6≥ 4.3.0, < 4.3.3< 4.1.9
| 4.2.64.3.34.1.9
|
| moodle | ≥ 4.1.0, < 4.1.9≥ 4.2.0, < 4.2.6≥ 4.3.0, < 4.3.3
| 4.1.94.2.64.3.3
|
Description
Separate Groups mode restrictions were not honored when performing a forum export, which would export forum data for all groups. By default this only provided additional access to non-editing teachers.
NVD description
Separate Groups mode restrictions were not honored when performing a forum export, which would export forum data for all groups. By default this only provided additional access to non-editing teachers.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free